$re = '/(#[A-Z](-\d+){3})/';
$str = 'Your order #Q-1-111-1111. Bill amount is $100.50';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);