using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^<table.+.(?:[n])?(?:.+)?)(<tbody>)";
string substitution = @"1<thead>";
string input = @"<table class=""table table-bordered table-responsive"" style=""width: 100%;"">
<tbody>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}