use strict;
my $str = '<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>';
my $regex = qr/(^<table.+.(?:[n])?(?:.+)?)(<tbody>)/msp;
my $subst = '1<thead>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";