package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(^<table.+.(?:[n])?(?:.+)?)(<tbody>)`)
var str = `<table class="table table-bordered table-responsive" style="width: 100%;">
<tbody>`
var substitution = "1<thead>"
fmt.Println(re.ReplaceAllString(str, substitution))
}