using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*\*(.+?)\*\*";
string input = @"**Hello, My name is
Name: enter**
**Designation is:
Field work**dgfdgdf
hfgf";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}