re = /\*\*(.+?)\*\*/
str = '**Hello, My name is
Name: enter**
**Designation is:
Field work**dgfdgdf
hfgf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end