#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)href="([^"]*+)""
Local $sString = "<a href="http:/my.domain/simple-product-2.html" class="product-image"><img src="http://my.domain/media/catalog/product/cache/1/small_image/75x/9df78eab33525d08d6e5fb8d27136e95/images/catalog/product/placeholder/small_image.jpg" width="75" height="75" alt="Simple Product 2" title="Simple Product 2"></a>" & @CRLF & _
"<div class="product-details">" & @CRLF & _
" <h3 class="product-name"><a href="http://my.domain/simple-product-2.html">Simple Product 2</a></h3>" & @CRLF & _
" <div class="price-box">" & @CRLF & _
" <span class="regular-price" id="product-price-2-related">" & @CRLF & _
" <span class="price">$42.00</span> </span>" & @CRLF & _
" </div>" & @CRLF & _
" <p><a href="http://my.domain/wishlist/index/add/product/2/form_key/PLOSE4N7mH4kcOgX/" class="link-wishlist">Add to Wishlist</a></p>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")