// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="([^"]*+)""#).unwrap();
let string = "<a href=\"http:/my.domain/simple-product-2.html\" class=\"product-image\"><img src=\"http://my.domain/media/catalog/product/cache/1/small_image/75x/9df78eab33525d08d6e5fb8d27136e95/images/catalog/product/placeholder/small_image.jpg\" width=\"75\" height=\"75\" alt=\"Simple Product 2\" title=\"Simple Product 2\"></a>
<div class=\"product-details\">
<h3 class=\"product-name\"><a href=\"http://my.domain/simple-product-2.html\">Simple Product 2</a></h3>
<div class=\"price-box\">
<span class=\"regular-price\" id=\"product-price-2-related\">
<span class=\"price\">$42.00</span> </span>
</div>
<p><a href=\"http://my.domain/wishlist/index/add/product/2/form_key/PLOSE4N7mH4kcOgX/\" class=\"link-wishlist\">Add to Wishlist</a></p>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}