# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"([^\"]*+)\""
test_str = ("<a href=\"http:/my.domain/simple-product-2.html\" class=\"product-image\"><img src=\"http://my.domain/media/catalog/product/cache/1/small_image/75x/9df78eab33525d08d6e5fb8d27136e95/images/catalog/product/placeholder/small_image.jpg\" width=\"75\" height=\"75\" alt=\"Simple Product 2\" title=\"Simple Product 2\"></a>\n"
"<div class=\"product-details\">\n"
" <h3 class=\"product-name\"><a href=\"http://my.domain/simple-product-2.html\">Simple Product 2</a></h3>\n"
" <div class=\"price-box\">\n"
" <span class=\"regular-price\" id=\"product-price-2-related\">\n"
" <span class=\"price\">$42.00</span> </span>\n"
" </div>\n"
" <p><a href=\"http://my.domain/wishlist/index/add/product/2/form_key/PLOSE4N7mH4kcOgX/\" class=\"link-wishlist\">Add to Wishlist</a></p>\n"
"</div>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.