package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z]+\.(?:jpg|png|gif),(?: [A-Z][a-z]+\.(?:jpg|png|gif),){3,}$`)
var str = `Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,
Chrysanthemum.jpg, Desert.png, Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg, Desert.png,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}