re = /^[A-Z][a-z]+\.(?:jpg|png|gif),(?: [A-Z][a-z]+\.(?:jpg|png|gif),){3,}$/m
str = 'Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,
Chrysanthemum.jpg, Desert.png, Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg, Desert.png,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end