const regex = /^[A-Z][a-z]+\.(?:jpg|png|gif),(?: [A-Z][a-z]+\.(?:jpg|png|gif),){3,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][a-z]+\\.(?:jpg|png|gif),(?: [A-Z][a-z]+\\.(?:jpg|png|gif),){3,}$', 'gm')
const str = `Chrysanthemum.jpg, Desert.png, Hydrangeas.gif, Jellyfish.jpg, Koala.jpg, Lighthouse.png,
Chrysanthemum.jpg, Desert.png, Hydrangeas.gif,
Chrysanthemum.jpg,
Chrysanthemum.jpg, Desert.png,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}