#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<div>\s*<p class="match">([\w\s]+)</p>[\w\s]+(?=<a class="a").*?</div>"
Local $sString = "<div>" & @CRLF & _
" <p class="match"> this sentence should match </p> " & @CRLF & _
" some text" & @CRLF & _
" <a class="a"> some text </a> " & @CRLF & _
"</div>" & @CRLF & _
"<div> " & @CRLF & _
" <p class="match"> this sentence should not match</p> " & @CRLF & _
" some text" & @CRLF & _
" <a class ="b"> some text </a> " & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" <p class="match"> this sentence should match </p> " & @CRLF & _
" some text" & @CRLF & _
" <a class="a"> some text </a> " & @CRLF & _
"</div>" & @CRLF & _
"<div> " & @CRLF & _
" <p class="match"> this sentence shouldn't match</p> " & @CRLF & _
" some text" & @CRLF & _
" <a class ="b"> some text </a> " & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")