# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div>\s*<p class=\"match\">([\w\s]+)</p>[\w\s]+(?=<a class=\"a\").*?</div>"
test_str = ("<div>\n"
" <p class=\"match\"> this sentence should match </p> \n"
" some text\n"
" <a class=\"a\"> some text </a> \n"
"</div>\n"
"<div> \n"
" <p class=\"match\"> this sentence should not match</p> \n"
" some text\n"
" <a class =\"b\"> some text </a> \n"
"</div>\n"
"<div>\n"
" <p class=\"match\"> this sentence should match </p> \n"
" some text\n"
" <a class=\"a\"> some text </a> \n"
"</div>\n"
"<div> \n"
" <p class=\"match\"> this sentence shouldn't match</p> \n"
" some text\n"
" <a class =\"b\"> some text </a> \n"
"</div>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.