import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div>\\s*<p class=\"match\">([\\w\\s]+)</p>[\\w\\s]+(?=<a class=\"a\").*?</div>";
final String string = "<div>\n"
+ " <p class=\"match\"> this sentence should match </p> \n"
+ " some text\n"
+ " <a class=\"a\"> some text </a> \n"
+ "</div>\n"
+ "<div> \n"
+ " <p class=\"match\"> this sentence should not match</p> \n"
+ " some text\n"
+ " <a class =\"b\"> some text </a> \n"
+ "</div>\n"
+ "<div>\n"
+ " <p class=\"match\"> this sentence should match </p> \n"
+ " some text\n"
+ " <a class=\"a\"> some text </a> \n"
+ "</div>\n"
+ "<div> \n"
+ " <p class=\"match\"> this sentence shouldn't match</p> \n"
+ " some text\n"
+ " <a class =\"b\"> some text </a> \n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}