import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:DE(?: \\d{3}){3}|DE ?[0-9]{9})(?!\\d)";
final String string = "I want to get this DE813992525 and this DE813992526 number and this number DE 813 992 526 and this number DE 813992526. I do not want the banc account number: IBAN DE06300501100011054517.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}