const regex = /\b(?:DE(?: \d{3}){3}|DE ?[0-9]{9})(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:DE(?: \\d{3}){3}|DE ?[0-9]{9})(?!\\d)', 'gm')
const str = `I want to get this DE813992525 and this DE813992526 number and this number DE 813 992 526 and this number DE 813992526. I do not want the banc account number: IBAN DE06300501100011054517.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}