$re = '/\b(?:DE(?: \d{3}){3}|DE ?[0-9]{9})(?!\d)/m';
$str = 'I want to get this DE813992525 and this DE813992526 number and this number DE 813 992 526 and this number DE 813992526. I do not want the banc account number: IBAN DE06300501100011054517.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);