import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<date>\\d\\d\\d\\d-\\w+-\\d\\d\\s+\\d\\d:\\d\\d:\\d\\d\\.\\d\\d\\d)\\s+(?<status>\\w+)";
final String string = "sometext 2021-Apr-08 23:08:23.498 ERROR somemoretext";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}