const regex = /(?<date>\d\d\d\d-\w+-\d\d\s+\d\d:\d\d:\d\d\.\d\d\d)\s+(?<status>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<date>\\d\\d\\d\\d-\\w+-\\d\\d\\s+\\d\\d:\\d\\d:\\d\\d\\.\\d\\d\\d)\\s+(?<status>\\w+)', 'gm')
const str = `sometext 2021-Apr-08 23:08:23.498 ERROR somemoretext`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}