re = /(?<date>\d\d\d\d-\w+-\d\d\s+\d\d:\d\d:\d\d\.\d\d\d)\s+(?<status>\w+)/m
str = 'sometext 2021-Apr-08 23:08:23.498 ERROR somemoretext'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end