#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=H\d{3}\b)(?:(?!\+?H\d{3}\b)[\S\s])+(?=[\s\S]*\r?\nEnd word\b)"
Local $sString = "Sample text" & @CRLF & _
"Sample text" & @CRLF & _
"Sample text" & @CRLF & _
"H319 asdkjczixuqweoiurqoiweqwrjasdkjfqwe qweiouqwroiu kjasdkj czkjxklqjwekjiouasdiiaosudou" & @CRLF & _
"oiuasodiucxzlkjqweoiu oqiwur H320 asdkqjwe askjdq xzc" & @CRLF & _
"H325 asjdhasjd zxcjh" & @CRLF & _
"H331+H341+H341 askdjvkjzx qweqrqwoe" & @CRLF & _
"End word" & @CRLF & _
"Sample text" & @CRLF & _
"Sample text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")