import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=H\\d{3}\\b)(?:(?!\\+?H\\d{3}\\b)[\\S\\s])+(?=[\\s\\S]*\\r?\\nEnd word\\b)";
final String string = "Sample text\n"
+ "Sample text\n"
+ "Sample text\n"
+ "H319 asdkjczixuqweoiurqoiweqwrjasdkjfqwe qweiouqwroiu kjasdkj czkjxklqjwekjiouasdiiaosudou\n"
+ "oiuasodiucxzlkjqweoiu oqiwur H320 asdkqjwe askjdq xzc\n"
+ "H325 asjdhasjd zxcjh\n"
+ "H331+H341+H341 askdjvkjzx qweqrqwoe\n"
+ "End word\n"
+ "Sample text\n"
+ "Sample text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}