import re
regex = re.compile(r"(?<=H\d{3}\b)(?:(?!\+?H\d{3}\b)[\S\s])+(?=[\s\S]*\r?\nEnd word\b)", flags=re.MULTILINE)
test_str = ("Sample text\n"
"Sample text\n"
"Sample text\n"
"H319 asdkjczixuqweoiurqoiweqwrjasdkjfqwe qweiouqwroiu kjasdkj czkjxklqjwekjiouasdiiaosudou\n"
"oiuasodiucxzlkjqweoiu oqiwur H320 asdkqjwe askjdq xzc\n"
"H325 asjdhasjd zxcjh\n"
"H331+H341+H341 askdjvkjzx qweqrqwoe\n"
"End word\n"
"Sample text\n"
"Sample text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")