const regex = new RegExp('(?<![,\\.])\\b(\\d+[,.]\\d+)\\b(?![.,]\\d)', 'gm')
const str = `| Task| Text | Capture |
|:---- |:------| :-----|
| Capture| 1.304 /XXX 0.0000 XX 15/Oct/2000 | 1.304 and 0.000 |
| Capture | XXX 1.304% - XXXX 15.10.2044 XXX | 1.304 but not part of the date 15.10.2044|
| Capture| XXX 11,8275% XXX1 AAA | 11,8275|
| Capture| XX 0.0. vs. 2.895 | 2.895 |
| Capture| XX 0.0. vs. 2.895. | 2.895 |`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}