re = /(?<![,\.])\b(\d+[,.]\d+)\b(?![.,]\d)/m
str = '| Task| Text | Capture |
|:---- |:------| :-----|
| Capture| 1.304 /XXX 0.0000 XX 15/Oct/2000 | 1.304 and 0.000 |
| Capture | XXX 1.304% - XXXX 15.10.2044 XXX | 1.304 but not part of the date 15.10.2044|
| Capture| XXX 11,8275% XXX1 AAA | 11,8275|
| Capture| XX 0.0. vs. 2.895 | 2.895 |
| Capture| XX 0.0. vs. 2.895. | 2.895 |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end