const regex = /(?=\|).(?=.*[\r\n]+\|-+\|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\|).(?=.*[\\r\\n]+\\|-+\\|$)', 'gm')
const str = `| A | B | C |
|-----------|
Ignore this line
| And | Ignore | This |
| D | E | F | G |
|---------------|`;
const subst = `^`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);