$re = '/(?=\|).(?=.*[\r\n]+\|-+\|$)/m';
$str = '| A | B | C |
|-----------|
Ignore this line
| And | Ignore | This |
| D | E | F | G |
|---------------|';
$subst = "^";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;