use strict;
my $str = '| A | B | C |
|-----------|
Ignore this line
| And | Ignore | This |
| D | E | F | G |
|---------------|';
my $regex = qr/(?=\|).(?=.*[\r\n]+\|-+\|$)/mp;
my $subst = '^';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";