using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b>(?:(?<!</b>).)*(?<!</b>)red.*?</b>";
string input = @"<b> </b>red</b>
<b></b> red</b>
<b></b>red</b>
<b>red</b>
<b> red </b>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}