$re = '~<b>(?:(?<!</b>).)*(?<!</b>)red.*?</b>~';
$str = '<b> </b>red</b>
<b></b> red</b>
<b></b>red</b>
<b>red</b>
<b> red </b>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);