re = /<b>(?:(?<!<\/b>).)*(?<!<\/b>)red.*?<\/b>/
str = '<b> </b>red</b>
<b></b> red</b>
<b></b>red</b>
<b>red</b>
<b> red </b>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end