# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\".*$/$0"/gm;t' <<< "\"text1
\"text2
\"text3"