#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\".*$"
Local $sString = ""text1" & @CRLF & _
""text2" & @CRLF & _
""text3"
Local $sSubst = "$0""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)