package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#\s*([^:]+?)\s*:\s*(.*?)\s*$`)
var str = `#Property Name : Property Value
#foo bar : stackoverflow
foo not bar : test
# bang : ding `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}