re = /^#\s*([^:]+?)\s*:\s*(.*?)\s*$/m
str = '#Property Name : Property Value
#foo bar : stackoverflow
foo not bar : test
# bang : ding '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end