package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*".*".*|.*?(\[\[.*?\]\]).*?`)
var str = `[[Hello]]
<tag Text="my [[Test]] is [[Test2]] for [[Test3]][[Test4]]">
<tag Text=my [[Test]] is [[Test2]] for [[Test3]][[Test4]]>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}