re = /.*".*".*|.*?(\[\[.*?\]\]).*?/
str = '[[Hello]]
<tag Text="my [[Test]] is [[Test2]] for [[Test3]][[Test4]]">
<tag Text=my [[Test]] is [[Test2]] for [[Test3]][[Test4]]>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end