$re = '/.*".*".*|.*?(\[\[.*?\]\]).*?/';
$str = '[[Hello]]
<tag Text="my [[Test]] is [[Test2]] for [[Test3]][[Test4]]">
<tag Text=my [[Test]] is [[Test2]] for [[Test3]][[Test4]]>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);