import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=int |float |String |double )([a-zA-Z_]\\w*)(?=,|;|\\s)|([a-zA-Z_]\\w*)(?=,|;|\\s*=)";
final String string = "private int functionName() {\n\n"
+ " int a;\n"
+ " int a = 100;\n"
+ " float b = 110;\n"
+ " String c = \"Hello World\";\n"
+ " double a, b, c, d = 1, e;\n\n"
+ " // ...;\n\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}