const regex = /(?<=int |float |String |double )([a-zA-Z_]\w*)(?=,|;|\s)|([a-zA-Z_]\w*)(?=,|;|\s*=)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=int |float |String |double )([a-zA-Z_]\\w*)(?=,|;|\\s)|([a-zA-Z_]\\w*)(?=,|;|\\s*=)', 'g')
const str = `private int functionName() {
int a;
int a = 100;
float b = 110;
String c = "Hello World";
double a, b, c, d = 1, e;
// ...;
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}