$re = '/(?<=int |float |String |double )([a-zA-Z_]\w*)(?=,|;|\s)|([a-zA-Z_]\w*)(?=,|;|\s*=)/';
$str = 'private int functionName() {
int a;
int a = 100;
float b = 110;
String c = "Hello World";
double a, b, c, d = 1, e;
// ...;
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);