const regex = /.+?(?=AA)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?(?=AA)', 'g')
const str = `354858 Some String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
543788 Another String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}