re = /.+?(?=AA)/
str = '354858 Some String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
543788 Another String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end