using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\||(?:\{(?:7f05059e-4b4c-4d4d-bb39-1f57446719ef|57cb8e77-30cb-4dba-88bb-104cfea2e94f|c41ac6b6-a5c9-47f9-86c2-7db9e861e701|97133d89-36a1-4c28-9f30-4516eb469520)\}))*$";
string input = @"|{7f05059e-4b4c-4d4d-bb39-1f57446719ef}{57cb8e77-30cb-4dba-88bb-104cfea2e94f}|{c41ac6b6-a5c9-47f9-86c2-7db9e861e701}|{97133d89-36a1-4c28-9f30-4516eb469520}
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}