$re = '/^(?:\||(?:\{(?:7f05059e-4b4c-4d4d-bb39-1f57446719ef|57cb8e77-30cb-4dba-88bb-104cfea2e94f|c41ac6b6-a5c9-47f9-86c2-7db9e861e701|97133d89-36a1-4c28-9f30-4516eb469520)\}))*$/';
$str = '|{7f05059e-4b4c-4d4d-bb39-1f57446719ef}{57cb8e77-30cb-4dba-88bb-104cfea2e94f}|{c41ac6b6-a5c9-47f9-86c2-7db9e861e701}|{97133d89-36a1-4c28-9f30-4516eb469520}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);