import Foundation
let pattern = #"^(?:\||(?:\{(?:7f05059e-4b4c-4d4d-bb39-1f57446719ef|57cb8e77-30cb-4dba-88bb-104cfea2e94f|c41ac6b6-a5c9-47f9-86c2-7db9e861e701|97133d89-36a1-4c28-9f30-4516eb469520)\}))*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
|{7f05059e-4b4c-4d4d-bb39-1f57446719ef}{57cb8e77-30cb-4dba-88bb-104cfea2e94f}|{c41ac6b6-a5c9-47f9-86c2-7db9e861e701}|{97133d89-36a1-4c28-9f30-4516eb469520}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}