#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?=.*\bdas\b)(?=.*\bist\b)(?=.*\bein Test\b)"
Local $sString = "das ist ein test" & @CRLF & _
"ein test das ist" & @CRLF & _
"ist das ein test" & @CRLF & _
"ist ein test das" & @CRLF & _
"ein ist das test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")