using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\bdas\b)(?=.*\bist\b)(?=.*\bein Test\b)";
string input = @"das ist ein test
ein test das ist
ist das ein test
ist ein test das
ein ist das test";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}