$re = '/(?=.*\bdas\b)(?=.*\bist\b)(?=.*\bein Test\b)/im';
$str = 'das ist ein test
ein test das ist
ist das ein test
ist ein test das
ein ist das test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);